Page 1 of 1

Export Mapping Issue - Mapping Gone

PostPosted: Tue Jul 07, 2015 3:40 pm
by ABQHPGuy
Has anyone encountered an issue where you are unable to export Mapping Definitions for interfaces because the Mapping section does not show up in the Export screen? Usually when you go to Action -> Export and scroll to the bottom, you have a list of Mappings to export. Selecting any will automatically select each element that is used within the mapping. However, recently in one of our environments (DEV unfortunately) we are unable to export any Mappings. The section just does not display at all, System Definition is the last section available for Export.

Any help would be fantastic!

Re: Export Mapping Issue - Mapping Gone

PostPosted: Wed Jul 08, 2015 4:27 pm
by Rhunt
Hi,

I have never heard of that occuring. It sounds like all Mappings are not displaying in that environment. Have you attempted to log into one of your other ConnectR servers (test or QA) and access the dev instance through IE and try the export from there?

http://servername/idxconnectr/default.asp

Re: Export Mapping Issue - Mapping Gone

PostPosted: Wed Jul 08, 2015 5:13 pm
by ABQHPGuy
Thank you for the suggestion, as it turns out, it's due to the System Definition name being more than 40 characters long. We went through a lot of digging to figure it out. Basically, the Name of a system is a varchar(100) in the database, but the stored procedure that pulls the list into the Export screen limits that field to 40 characters. When the call is run from ConnectR, the sp is returning an error but ConnectR does not display that and it appears as if the Mappings secion just doen't want to display.